[VIDEO] Excel – Les fonctions RechercheV RechercheH Faîtes parler vos données !

Aujourd’hui, nouvelle fonction Excel: la recherche Verticale et horizontale respectivement RECHERCHEV et RECHERCHEH.

 

La chose la plus importante avec ces formules est de comprendre l’intérêt et le fonctionnement, pour cela je vous conseil évidemment de regarder la vidéo ! Mais le texte ci-dessous pourra vous aider.

Les fonctions recherche fonctionnent globalement en deux étapes:

  1. Rechercher la donnée demandée, dans le tableau demandé.
  2. Renvoyer la donnée correspondante demandée.

Dis comme ça, ça n’est pas forcément clair, mais voyons ça un peu plus en détails.

 

Structure des fonctions RECHERCHEV RECHERCHEH.

Je vous présente dans un premier temps la fonction RECHERCHEV et on verra un peu plus bas les différences entre les 2 formules, sachez que le fonctionnement et la structure son exactement les mêmes

Structure RECHERCHE V

 

On a ici 3 éléments qui correspondent exactement au fonctionnement que je vous présentais plus haut:

  1. L’élément à rechercher,
  2. La plage de recherche/ de travail (cette plage de données doit comprendre le résultat à renvoyer)
  3. Le N° de colonne/ligne à renvoyer: c’est à dire le numéro de colonne pour une Recherche Verticale.

Le 3ème numéro est le plus important à comprendre. Pour cela, regardez ce tableau:

tableau exemple Recherche V

Si l’on demandait à Excel de rechercher verticalement le numéro 9 et de renvoyer la 2 colonne, soit =RECHERCHEV( 9 ; A1:C12 ; 2 )

le logiciel procéderait comme ça:

  1. Parcours de la première colonne de A1:C12 : 1 -> 9; le numéro 9 est trouvé en A10.
  2. Renvoyer les données de la 2eme colonne: Renvoyer B10 soit Paul.

C’est aussi simple que ça !

Avec ça, vous pouvez automatiser des recherches en fonction de données variables, comme dans la vidéo où je vous présente une recherche en fonction d’une date modifiable.

Différence entre la Recherche Horizontale et Verticale.

Voilà un dernier point important à comprendre pour maîtriser ces fonctions.

Lors d’une recherche Verticale, Excel résonne de “bas en haut”, il va donc rechercher en premier dans la première colonne de A1 à A… puis renvoyer le résultat demandé dans une autre colonne soit Ax, Bx, Cx, etc…

  • Orange: la donnée recherchée,
  • Bleu: La plage de recherche,
  • Jaune: le numéro à renvoyer.

Fonctionnement RechercheV

 

Pour RECHERCHEH, on va simplement inversé le tableau comme cela:

Fonctionnement RechercheH

 

Ici, Excel va chercher de gauche à droite dans la première ligne, puis renvoyer le résultat correspondant sur une autre ligne.

Si le résultat est trouvé en C2, il renverra soit C2, D2, E2, F2, etc…

 

Voilà c’est tout ce que j’avais à vous présenter sur les fonctions de recherche !

N’hésitez pas à me poser vos questions dans les commentaires, et si ça vous a vraiment aider mettez un “j’aime” sur la vidéo, ça me fera très plaisir !

Je vous dit à bientôt pour la suite ! 

Téléchargez toutes les fiches utilisés dans la vidéo:

 

Matthieu Langlade Article écrit par Matthieu Langlade - Google +

Passionné de la suite Office et tout particulièrement de PowerPoint, ses possibilités et la "slidologie", je souhaite partager mes connaissances et donner des idées pour sortir des standards que l'on s'impose.

3 thoughts on “[VIDEO] Excel – Les fonctions RechercheV RechercheH Faîtes parler vos données !

  1. Bonjour,
    Je suis assistante dans l’entreprise de mon mari. Pour un meilleur suivi de mes factures, j’ai fait un tableau excel ou il est noté : nom du clt, adresse du clt, CP, ville, n° fact, date de fact, date d’envoi de la fact, date d’échéance, relance 1 à échéance+30j, relance 2 à relance1+30j et relance3 à relance 2 + 30j.
    Je souhaiterais que lorsque les différentes dates de relances arrivent (par exemple aujourd’hui), excel envoi vers mon Outlook un message “tache à effectuer” dans laquelle il serait noté par exemple relance Mme X (je voudrais que ça passe par outlook car j’ouvre ce logiciel tous les jours contrairement à excel). Aujourd’hui je suis obligée de le faire manuellement dans outlook et cela est très fastidieux.
    Merci pour votre réponse (en espérant avoir été claire et qu’il y ait une solution à mon problème).
    Bonne journée.

    • Bonjour,
      C’est une très bonne question, malheureusement je n’ai pas de remède car je ne connais pas très bien Outlook !

      De ce que je connais de Outlook, il est possible de faire des rappels avec une périodicité (Tout les 30j/mois/semaines/etc…), à voir s’il est possible de résoudre le problème comme ça.

      Du côté Excel, il va y avoir des problèmes.
      1. Oui il est possible de détecter quel client est à relancer, avec une condition “Si la date de rappel = la date d’aujourd’hui, alors Rappel moi” qui se traduit par:
      =Si(Aujourdhui()=cellule.de.date.de.rappel;RAPPEL;PAS.DE.RAPPEL)
      A voir ensuite, il doit être possible d’envoyer une informations vers un logiciel externe comme Outlook.

      2. Le problème est: pour que Excel traite la date d’aujourd’hui, il faut que le fichier soit actif et donc ouvert !

      Bref, au final je pense que c’est une grosse complication ! Essayez plutôt de voir du côté des rappels Outlook (dans la gestion du calendrier).

      Bonne continuation, n’hésitez pas à me tenir au courant de l’avancement !

  2. Bonjour,

    je souhaiterais connaître, au sein d’une table présentant plusieurs colonnes, le nombre de données X d’une colonne
    contenant des données X, A, B,C… .

    Concrètement, j’ai un tableau présentant des relevés (A, B, C) effectués sur plusieurs années (1982 à 1991), et plusieurs mois (janvier à décembre).
    Au sein de chaque année, je voudrais connaître, par exemple, dans ma colonne “Relevés”, combien de “B” ont été relevés en février 1984 ?

    Avec :
    Colonne A = Années
    Colonne B = Mois
    Colonne C = Relevés contenant A, B et C

    (environ 4000 lignes)

    J’ai testé avec RECHERCHEV en mettant
    =RECHERCHEV(B,A1:C4000,C:C,FAUX)
    mais j’obtiens #NOM?…

    Que puis-je faire ?

    Vous remerciant par avance !

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *