Fonctions Excel: NB, NB.SI, NB.VIDE, NBVAL – Comptez ses cellules vides/pleines

Lorsque l’on travail sur des gros fichier Excel, il est parfois utile de pouvoir compter combien de cellules contiennent un certain type de données.

Aujourd’hui je vous propose de découvrir 4 formules qui vont permettre de répondre à ce type de question:

 

Combien de cellules sont vides dans mon tableau ?

Combien de cellules contiennent exactement ce nom ?

Combien de cellules sont utilisés dans mon fichier Excel ?

Combien de cellules contiennent des chiffres dans ma plage de données ?

Quatre questions pour quatre formules assez simples, mais très utiles. Le genre de formule qu’il faut toujours avoir en tête car elles solutionnent souvent des problèmes !

Pour commencer, je vous présente la plus utile dans la plus part des cas.

Compter les cellules contenant des données précises: =NB.SI

Cette formule est en quelque sorte une combinaison d’un NB et d’une formule si, on l’a d’ailleurs abordé une première fois lors de la découverte des listes déroulantes, permettant d’extraire des données rapidement.

Elle va donc permettre de compter combien de cellules correspondent à une condition.

La structure reste simple:

Structure formule excel NB.SI()

=NB.SI( PLAGE , CONDITION)

Par exemple =NB.SI(A1:E150,”Georges”) affichera le nombre de fois où Georges apparaît dans le tableau.

On peut également y afficher une formule dans la condition, par exemple =NB.SI(A1:A150;B1+B2). La formule va d’abord calculer B1 + B2 puis chercher dans le tableau.

Voilà l’exemple utiliser dans la vidéo:

Exemple formule excel NB.SI

 

 

 

Compter des cellules contenant des nombres/chiffres/ données numériques: =NB( )

Avant tout, il est important de comprendre que l’on parle bien de nombres affichés par les cellules. Si vous avez une formule dans la cellule qui renvoie un nombre, la formule la comptera.

Comme souvent, attention à bien utiliser une virgule pour des nombres à décimal (et pas un point), dans le cas contraire, cela pourrait ne pas être considéré comme un nombre.

La structure est extrêmement simple tout comme toutes les prochaines formules :

=NB (plage de cellules)

Par exemple =NB(A1:E150) affichera le nombre de cellules contenant des données numériques.

Compter des cellules contenant autre chose que des nombres (caractères): =NBVAL( )

Attention avec cette formule ! Il n’y a pas de point entre NB et VAL, la raison provient surement du nom anglais de la formule, mais je n’ai pas pousser la recherche :).

Cette formule est la complémentaire de NB(), car elle va renvoyer le nombre de cellules contenant des caractères, c’est à dire qu’elle ne comptera ni les cellules vides, ni les cellules contenant des nombres.

Comme pour les autres formules, on retrouve la même structure:

=NBVAL (plage de cellules) 

Par exemple, =NB(A1:A150), renverra le nombre de cellules contenant des caractères/chaîne de caractères.

Compter des cellules vides : =NB.VIDE( )

Magie de la formule, on retrouve ici le point entre NB et VIDE (attention à ne pas confondre).

Cette formule va tout simplement renvoyer le nombre de cellules ne contenant rien ! Encore une fois, les formules ne sont pas prises en compte, donc si une formule ne renvoie aucun résultat dans une cellule, elle sera prise en compte dans NB.VIDE.

On retrouve la même structure:

=NB.VIDE (plage de données)

Pour résumer :

Structure formule excel NB NB.VIDE NBVAL

 

 

Quelques exemples d’utilisations pour NB, NBVAL et NB.VIDE.

Voilà les exemple que j’ai abordé dans la vidéo:

Exemples formule excel NB NB.VIDE NBVAL

=NB ( ) va permettre de compter combien de journées numérotées sont passées. Dans cet exemple, cela va permettre de calculer le nombre de ligne et en insérer une nouvelle à la fin à l’aide d’une macro Excel.

=NB.VIDE ( ) va permettre de compter le nombre de postes qui n’ont pas été occupés pendant une période.

= NBVAL ( ) nous a permis de compter, à l’inverse, le nombre de postes occupés pendant la période.

 

J’espère que ces formules vous aideront !

N’hésitez pas à commenter si vous avez rencontrés des problèmes ou simplement si ça vous a aidé :). 

A bientôt !

Matthieu Langlade Article écrit par Matthieu Langlade - Google +

Passionné de la suite Office et tout particulièrement de PowerPoint, ses possibilités et la "slidologie", je souhaite partager mes connaissances et donner des idées pour sortir des standards que l'on s'impose.

28 thoughts on “Fonctions Excel: NB, NB.SI, NB.VIDE, NBVAL – Comptez ses cellules vides/pleines

  1. Bonjour,

    comment faire avec la fonction NB.SI lorsque je désire compter les cases contenant une valeur spécifique, mais que ces plages ne sont pas contiguës?

    Par ex., sur une ligne, je voudrais savoir combien de fois une case contient la valeur ‘1’, mais uniquement dans certaines case (A4, E4, I4, L4) et pas sur toute la ligne ?

    Merci

    • Bonjour Jean-Luc,

      je pense que tu peux faire de deux façons différentes :
      =SOMME(NB.SI(B4;”1″);NB.SI(E4;”1″);NB.SI(I4;”1″);NB.SI(L4;”1″))
      Une somme des différents nombres présents dans les cellules choisies.
      ou

      =B4+E4+I4+L4
      une simple addition.

      Je sais si ca répond à ta question.

  2. bonjour,
    j’ai utilisé la formule nb() dans ma colonne
    maintenant je souhaiterais à partir de cette colonne refaire la même chose
    sauf que du coup les valeurs 0 compte alors que je ne veux pas comment faire ?

  3. Bonjours,
    J’ai une liste de réponses données lors d’un questionnaire en ligne et j’aimerai savoir s’il y a un moyen d’en faire une stat ex:
    =nb.si (A1:A24;”oui”) pour les réponses oui
    =nb.si(A1:A24;”non”) pour les réponses non

    Mais comment compter les réponses autre que oui et non?

    Merci

  4. Hey!

    Merci pour ces infos, pratique quand on a un petit oubli 🙂

    J’ai remarqué une petite erreur dans le paragraphe NBVAL, sur cette phrase:

    Par exemple, =NB(A1:A150), renverra le nombre de cellules contenant des caractères/chaîne de caractères.

    Ce n’est pas NB mais NBVAL comme tu l’expliques dans ton paragraphe 😉

  5. Bonjour, besoin de votre aide svp.
    j’ai besoin de connaître comment sur Excel je peut compter le nombre de ligne contenant au moins une valeur (numérique ou alphabétique) dans une plage donner d’une feuille?

  6. Bonjour et merci pour ces précieux conseils.
    J’ai moi aussi un petit souci.
    Comme savoir si toutes les cellules d’une plage sont des cellules “numériques” ?
    ATTENTION je ne veux pas les compter.

    Par avance merci

    LADAURADE

    • Bonjour,
      Pour savoir si toutes les cellules sont numériques, il suffit de demander au logiciel s’il y’en a au moins une ! Et donc de les compter en Premier 🙂
      =Si(NB(A1:A1000)<0;"Il n'a pas de cellule numérique";"Il y a au moins une cellule numérique")

  7. Salut,

    J’ai une question, j’ai des tableaux Excel avec une grande quantité d’information et je souhaite faire une recherche sur deux colonnes afin de déterminer combien de fois j’ai le chiffre 1 avec le chiffre 1, puis le chiffre 1 avec le chiffre 2, puis avec le 3 et ainsi de suite…
    Je ne trouve pas quelle est la fonction qui pourrait me permettre de faire cela?
    Peux-tu m’aider dans ma démarche?
    Cordialement Tino

  8. Bonjour,
    Je fais de la Généalogie et j’ai un classeur Excel qui comporte un certain nombres de feuilles , mais combien ?, peut être plus de 400 ?.
    J’aimerais savoir le nombre de feuilles utilisées dans mon classeur.
    Merci à l’avance pour votre aide.
    Bien cordialement,
    Claude Desnos

  9. ligne avec des noms :ex A1 bernard A2 pierre A3 pierre A4 pierre A5 joel pierre
    résultat cherché enA6 :bernard.pierre.joel

    avez vous une idée de formule

    merci fred

  10. Bonjour, merci d’abord pour votre tutoriel qui m’est d’une grande aide dans ma thèse, j’aurais cependant une question :
    Lorsque je veux calculer le nombre de données “-0” ou “-1″ dans mon tableau, celui ci l’execute, simplement je me retrouve a devoir recopier ma formule pour chaque ligne.
    Or j’ai plus de 1000 lignes a effectuer… n’y a-t-il pas un moyen de décliner la formule en fonction du nombre de lignes ?

    Ex ma formule est =NB.SI(lundi!A3:lundi!Y3;”-0″)/2 mais actuellement je ne sais comment faire prendre mon ensemble de ligne et ne pas modifier manuellement A4Y4, A5:Y5, A6:Y6…

    Je vous remercie par avance

    • Bonjour et merci pour ce commentaire !

      De ce que je comprends la solution est juste de modifier la formule sur la première ligne en disant “compte de la première à la ligne 1000”.

      =NB.SI(lundi!A3:lundi!Y1000;”-0″)/2

      Et ça devrait fonctionner 🙂

  11. Bonjour et merci pour ce super tuto.
    J’ai tout de même une question : est ce possible de compter le nombre de ligne dans une même cellule ou autrement dit le nombre de fois dans une cellule où a été employé le Alt+Entrée.

    Merci d’avance de ta réponse !

  12. Bonjour,

    Cette formule est sur ma feuille =NBVAL(tblAvril[@[1]:[29]]) j’aimerai pouvoir déduire du résultat selon un caractère qui est dans ce cas “R” avec le nom “CléRepos” faisant référence à =Janvier!$K$13. Comment faire ?

    Merci.

  13. Bonjour,

    Je cherche à demander à Excell de me déterminer le nombre de cellule d’une colonne n’étant pas rempli d’une couleur ou l’autre tout en tenant compte que mon tableau est entièrement quadrillé.

    Par avance merci pour votre aide

  14. Bonjour pouvez vous me donner la formule pour compter combien de fois sur une même ligne il y a de postes de planifier sur Excel je veux compter que les postes en lettres mais pas les chiffres
    merci beaucoup

  15. Bonjour, dans la formule NB.SI je voudrais rentrer le critère “strictement supérieur à 0.5 “, autrement dit j’aimerais que les nombres de ma plage supérieur à 0.5 soit afficher, j’ai essayé avec le signe mais Excel ne l’accepte pas comme formule. Pourriez vous m’aider s’il vous plait ?

  16. Bonjour, je suis confronté à un cas.
    sur une semaine, un chauffeur ne doit pas travailler 7 jours d’affilé. chaque jour je vérifie pour voir si sur les 7 derniers jours, les chauffeurs ayant travaillé ont fait 7 jours de travail oub moins que ca. et donc j’ai besoin de compter le nombre de fois qu’ils ont travaillé. cependant une contrainte s’ajoute, c’est à dire si le chauffeur se repose un jour, il faudrait que ma formule puisse commencer à compter à le jours où il aura repris le service après son repos.
    autrement dit Une fois que le nom n’apparaît pas dans l’un des jours (par exemple le jeudi), j’aimerai que la fonction recommence à compter à partir du jour où le nom apparaîtra (par exemple le vendredi).

    besoin de votre aide.

    • Bonjour,

      Comme ça, je pense qu’il faut compter le nombre de fois où apparait le nom dans les 7 dernières cellules.

      Par exemple, Sur la ligne 1 les jours, ligne 2 les noms des chauffeurs et ligne 3 le nombre de jours travaillés ces 7 derniers jours.
      En – A3: =NB.SI(A2:A2;[Nom Chauffeur])
      – B3: =NB.SI(A2:B2;[Nom Chauffeur])
      – C3: =NB.SI(A2:C2;[Nom Chauffeur])
      […]
      – G3: =NB.SI(A2:G2;[Nom Chauffeur])
      – H3: =NB.SI(B2:H2;[Nom Chauffeur])

      etc… (en étendant la formule)

      Ca me semble être la solution la plus simple. On peux aussi trouver des solutions un peu plus compliqués avec par exmemple un EQUIV(….) qui renverra la position de la valeur cherchée, ou avec des positions relatives. Mais je pense que ça engage trop de complications pour un résultat quasi-similaire.

      A voir selon la disposition de votre tableau si cette solution s’adapte bien.

      Cdt,

  17. Merci pour votre tutoriel qui m’a bien aidée.
    Bravo pour le partage et le temps consacré à la réalisation de ces vidéos.
    Cordialement,

    Maryse

Répondre à Matthieu Langlade Annuler la réponse.

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *